AnyBackup - GoldenDB 数据库恢复出现警告,提示:“应用 binlog失败 1062 主键冲突”

问题描述

GoldenDB 数据库恢复之后,提示"应用 binlog 失败,ERROR 1062"。

问题影响

数据库恢复有告警。

问题原因

数据库恢复的过程中,未禁用租户,导致在恢复的过程中,主键信息往后推进,以至于后续应用 binlog 的时候出现主键冲突的报错。

解决方案

为了解决该问题,禁用恢复的租户后,再进行数据库恢复,请按照以下步骤执行:

  1. 登录 insight 管理界面
  2. 禁用恢复的实例,禁用方式如下:
    • 在实例管理页面找到目标实例
    • 点击"禁用"按钮
  3. 重新发起数据库恢复。
上一篇 AnyBackup - 云数据库 GaussDB 备份失败,提示登录ServiceOM查看实例任务
下一篇 AnyBackup - Sangfor Cloud Platform 恢复提示错误信息: IPv4地址和网关不在同一网段
易读格

易读格管理员

易读存知,格聚运维。

本月创作热力图

少
多
目录
最新评论
暂无评论